Quantcast
Having trouble installing addons? - WoWInterface
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
01-30-08, 11:34 AM   #1
Seerah
Fishing Trainer
 
Seerah's Avatar
WoWInterface Super Mod
Featured
Join Date: Oct 2006
Posts: 10,747
Having trouble installing addons?

Do you want to start using addons, but can't seem to get them installed correctly?
Do your friends keep telling you that you need to try a mod, but you just can't wrap your head around how to do it?



There are many places for you to look for help.



This site has a great FAQ for installing mods. You can always find it again by clicking the "Help & F.A.Q." link up at the top of every page on the site.


If you use Vista, there are some peculiarities with Vista's security/permissions that can make it difficult and confusing. Read through Shirik's Vista Users - UAC and You sticky in this forum. More help on Vista can be found in the official WoW Tech Support forum. Also, make sure you are installing the addons to the correct location. With a recent patch, WoW would have asked you if you would like to move the game out of the Program Files directory. If you answered "yes", your WoW folder is now located at C:\Users\Games\World of Warcraft. This is the directory you need to install to. Anything left at C:\Program Files\World of Warcraft can be deleted.


If you use a Mac, then check out the Mac Support forum on the WoW site. (Though addons are platform independent.)


There are a lot of guides and videos around the net to help you as well. Here's one that I made.


The UI & Macros forum on the WoW site can be a great help as well. Here is a guide written by Lopeppeppy (edited by Troodi and Unkle) that is plastered all over that forum.

Where is my addons menu!!? Lopeppeppy's Guide on Mod Installation

If the button doesn't appear on the WoW interface it's because the mods aren't installed correctly, (or alternatively, none installed at all).

1. Make sure you only have one copy of WoW installed and addons are in the correct directory. After a reinstall there is the possibility of having two or more copies of WoW on the same system and the addons have been inserted into the wrong folder. This is also common for Windiws Vista users as Patch 3.0.2 or the WotLK installer ask to move your WoW to a non-protected folder.

● Using Repair Tool: When the repair tool is run the Interface and WTF folders get renamed with the date added to the file name. This means those addons won't get loaded.

2. Make sure you are unzipping/uncompressing your addons. WinZip, WinRar, 7zip and StuffIt (for Mac) are common unzipping programs. WinZIP users: You MUST make sure the option to "Use Folder Names" is CHECKED or it will just extract the files and not make the proper folders as per the mod Authors structured directory paths.

3. Make sure that you aren't installing addons while WoW is running. WoW doesn't register addon changes until you logout and then back in, so save yourself some frustration and install while logged out and WoW is not running. Log in to check them, log back out as necessary to fix things.

4. Check the "Load Out of Date Addons" button on your Addons screen (when you install them properly, or if you already have some installed).

5. If using Windows VISTA see this article:

How-To: Trouble-Shoot AddOns under Vista by Lunessa/Unkle: http://forums.worldofwarcraft.com/th...57867106&sid=1

6. For Mac Users: Check spelling. Make sure the AddOns folder is named and matches exactly the capital letters and spelling to be: AddOns (The "O" is a capital letter and not the number zero "0")

● Some other things to check ●

The most common error is that the unzipper program embedded them into an extra folder layer. If you have any questions about whether your addons are embedded one folder too deep, post a path for the .toc file of each addon

Windows XP:
C: \Program Files\World of Warcraft\Interface\AddOns\MODFolder\ModName.toc

Windows Vista:
C: \users\public\games\World of Warcraft\World of Warcraft\Interface\AddOns\MODFolder \ ModName.toc

INCORRECT EXAMPLE (the addons will not load properly.):
Windows XP/Vista:
..\World of Warcraft \Interface\AddOns\MODFolder1.23.456\MODFolder\ModName.toc

Mac OSX:
../World of Warcraft/Interface/AddOns/MODFolder1.23.456/MODFolder/ModName.toc

There should only be one path-step between the AddOns step and the .toc step, and it should be the name of the addon (most usually). Look very closely at the directory structure, make sure that the addon's folder is in the proper place.

Standard Interface Guide
http://forums.worldofwarcraft.com/th...381215&sid=1#3

Excellent FAQ
http://www.wowinterface.com/forums/f..._howto_install

Sample screen of file directory structure (Macs have same basic structure, though some minor differences)
http://www.wowinterface.com/storage/faq/correct.gif

WoW Addon Install Tutorial Nice video by Seerah.

[yt]http://www.youtube.com/watch?v=dylXGXET8OA[/yt]

* * * *

If all else fails, just ask any questions you have. Remember, all you have to do to get rid of those mods is delete the Interface folder. The Blizzard mods inside will be recreated the next time you start the game.
__________________
"You'd be surprised how many people violate this simple principle every day of their lives and try to fit square pegs into round holes, ignoring the clear reality that Things Are As They Are." -Benjamin Hoff, The Tao of Pooh


Last edited by Seerah : 04-17-11 at 08:49 PM. Reason: embedded video
  Reply With Quote
 

WoWInterface » AddOns, Compilations, Macros » AddOn Help/Support » Having trouble installing addons?

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off