WoWInterface (
-   AddOn Help/Support (
-   -   Having trouble installing addons? (

Seerah 01-30-08 11:34 AM

Having trouble installing addons?
Do you want to start using addons, but can't seem to get them installed correctly?
Do your friends keep telling you that you need to try a mod, but you just can't wrap your head around how to do it?

There are many places for you to look for help.

This site has a great FAQ for installing mods. You can always find it again by clicking the "Help & F.A.Q." link up at the top of every page on the site.

If you use Vista, there are some peculiarities with Vista's security/permissions that can make it difficult and confusing. Read through Shirik's Vista Users - UAC and You sticky in this forum. More help on Vista can be found in the official WoW Tech Support forum. Also, make sure you are installing the addons to the correct location. With a recent patch, WoW would have asked you if you would like to move the game out of the Program Files directory. If you answered "yes", your WoW folder is now located at C:\Users\Games\World of Warcraft. This is the directory you need to install to. Anything left at C:\Program Files\World of Warcraft can be deleted.

If you use a Mac, then check out the Mac Support forum on the WoW site. (Though addons are platform independent.)

There are a lot of guides and videos around the net to help you as well. Here's one that I made.

The UI & Macros forum on the WoW site can be a great help as well. Here is a guide written by Lopeppeppy (edited by Troodi and Unkle) that is plastered all over that forum.


Where is my addons menu!!? Lopeppeppy's Guide on Mod Installation

If the button doesn't appear on the WoW interface it's because the mods aren't installed correctly, (or alternatively, none installed at all).

1. Make sure you only have one copy of WoW installed and addons are in the correct directory. After a reinstall there is the possibility of having two or more copies of WoW on the same system and the addons have been inserted into the wrong folder. This is also common for Windiws Vista users as Patch 3.0.2 or the WotLK installer ask to move your WoW to a non-protected folder.

● Using Repair Tool: When the repair tool is run the Interface and WTF folders get renamed with the date added to the file name. This means those addons won't get loaded.

2. Make sure you are unzipping/uncompressing your addons. WinZip, WinRar, 7zip and StuffIt (for Mac) are common unzipping programs. WinZIP users: You MUST make sure the option to "Use Folder Names" is CHECKED or it will just extract the files and not make the proper folders as per the mod Authors structured directory paths.

3. Make sure that you aren't installing addons while WoW is running. WoW doesn't register addon changes until you logout and then back in, so save yourself some frustration and install while logged out and WoW is not running. Log in to check them, log back out as necessary to fix things.

4. Check the "Load Out of Date Addons" button on your Addons screen (when you install them properly, or if you already have some installed).

5. If using Windows VISTA see this article:

How-To: Trouble-Shoot AddOns under Vista by Lunessa/Unkle:

6. For Mac Users: Check spelling. Make sure the AddOns folder is named and matches exactly the capital letters and spelling to be: AddOns (The "O" is a capital letter and not the number zero "0")

● Some other things to check ●

The most common error is that the unzipper program embedded them into an extra folder layer. If you have any questions about whether your addons are embedded one folder too deep, post a path for the .toc file of each addon

Windows XP:
C: \Program Files\World of Warcraft\Interface\AddOns\MODFolder\ModName.toc

Windows Vista:
C: \users\public\games\World of Warcraft\World of Warcraft\Interface\AddOns\MODFolder \ ModName.toc

INCORRECT EXAMPLE (the addons will not load properly.):
Windows XP/Vista:
..\World of Warcraft \Interface\AddOns\MODFolder1.23.456\MODFolder\ModName.toc

Mac OSX:
../World of Warcraft/Interface/AddOns/MODFolder1.23.456/MODFolder/ModName.toc

There should only be one path-step between the AddOns step and the .toc step, and it should be the name of the addon (most usually). Look very closely at the directory structure, make sure that the addon's folder is in the proper place.

Standard Interface Guide

Excellent FAQ

Sample screen of file directory structure (Macs have same basic structure, though some minor differences)

WoW Addon Install Tutorial Nice video by Seerah.


* * * *

If all else fails, just ask any questions you have. Remember, all you have to do to get rid of those mods is delete the Interface folder. The Blizzard mods inside will be recreated the next time you start the game.

obedwon 03-26-08 10:10 PM

add on helplz
Why dont i have a add on tab on my character screen??

Seerah 03-26-08 10:58 PM

Did you follow all of the guides and instructions provided?

rkb5 03-29-08 09:37 AM

hi, iv got the correct pathways for my addons as per the instructions on this website but i still have no addons button on my screen, i have noticed that if u click the addon my computer says that it doesnt recognize it & shud it use the internet to find a programme to run it - i clicked yes bt all it said was that it was an unknown file & to combat this i shud contact sum1 to find out wot programme i shud use.
can sum1 help me out plz? all i wanted was map co-ords! :(

Arabeth 03-29-08 10:11 AM

Sounds like you are clicking directly on the *.lua file that is included in the addon's folder.

This is not a file that runs in Windows. WoW effectively incorporates this file into the game and the game uses it to produce whatever effect the programmer was intending (usually :-)).

Your addon file structure should be something like...

C:\World of Warcraft\Interface\Addons\YourNewAddonFolder

Unless there is a problem with your system in that it cannot access the files in that directory, WoW should read the file.

There is a difference between the operating system allowing access to files and the program (WoW) interpreting the data (code) within it. Your operating system has a layer(s) of security that could prevent a user access to the file, which would prevent any application doing so.

Gemini_II 03-29-08 12:44 PM

Click on Seerah's video. You need to install WinZip or WinRAR.

Seerah 03-29-08 05:42 PM

Windows has an extraction utility - at least XP and Vista do...

Gemini_II 03-30-08 12:14 AM

True. Been too long since using it to remember, lol.
The OP must be trying to open the addon files themselves then. In which case refer back to Seerah's video. :)

flaviu tomuta 04-14-08 08:29 PM

Quick question??
How do i use two different UI's for two different characters??

Seerah 04-14-08 09:07 PM

Two different UI compilations? The easiest way is to have two separate Interface and WTF folders, renaming them depending on which character you're using. But you'll have to completely exit the game when changing characters. The other way is to use different profiles in your mods for each character.

eyehatehippies 04-26-08 04:02 PM

I followed the instructions to the letter on how to install. Made sure i only had 1 WoW directory. Made sure there was only 1 folder with add-on's name on it., etc. Extracted the files using WinZip 10.0, and it's still doing nothing. A little help?

Seerah 04-26-08 08:08 PM

It would help if you gave more information. Like what OS you're on, what addon you're trying to install, and what "it's still doing nothing" means exactly. ;)

Tman21 05-21-08 06:03 PM

yeah im trying to install Atlas Cartagrapher and Lightheaded. I put them in the addon folder extract them but nothing happens.

Seerah 05-21-08 08:03 PM

Did you watch the video and/or look at the pictures in the FAQ to make sure that you're doing it correctly? Give the full path to the LightHeaded.toc file.

Gemini_II 05-21-08 11:49 PM

Or post a screenshot of your folders :)

Tman21 05-22-08 04:15 PM

how do you take a screenshot? i have a bunch of other folders in my addon like Blizzard_Auction UI are those supposed to be there or somewhere else? here is the link for the lightheaded i downloaded

Tman21 05-22-08 04:30 PM

hey nvm i got it. thx for the help you guys :D:banana:

loganz 06-10-08 02:25 AM

Help meh out?
everytime i download an addon it pops up a thing that says open save close.
i click open and it goes to my folders and when i try to go to WoW and click the addon button it doesn't show the addon i downloaded only shows my other i downloaded from a diff site why wont it show the addon i downloaded here?

Seerah 06-10-08 07:41 PM

Don't click "Open". Click "Save".

Mithessar 06-17-08 01:04 PM

Add-ons installed, invisible in-game
Hey folks,

I just reinstalled WoW on a new hard drive - it all went smoothly until I tried to reinstall my add-ons. I'm running Windows xp pro on a Compaq nc8430 laptop. Here's what I've got:

Using WoW Ace, I downloaded/installed Cartographer, Omen, DrDamage, and Quartz into the following path:
C:\Program Files\World of Warcraft\Interface\Addons\[addon-name] for example,
C:\Program Files\World of Warcraft\Interface\Addons\DrDamage\DrDamage.toc

The good:
When I log in to WoW, I see the addons button on the bottom left of the character selections screen. They all appear to be functional/updated, and I can activate different addons for different characters.

The bad:
When I select a character and enter the game, I see no addons. I do not see the addon manager around the minimap, and commands such as /omen do nothing. Looking through every interface/graphics option I can find, I can see no way to access the supposedly enabled add-ons.

What I've tried:
Restarting WoW
Deleting & reinstalling add-ons
Disabling & re-enabling addons
Logging in with different characters

Obviously, it'd be really great to get this working soon; it's hard to raid without a threat meter! Thanks much,


Seerah 06-17-08 02:22 PM

My guess is that you told WAU to download WITHOUT externals and you do not have the libraries needed to run your addons. You also probably have error reporting turned off in Interface Options (I don't recall if it's off by default).

Go back to WAU and it's preferences, make sure default mode is WITH externals, and then reinstall all addons WITH externals.

Arabeth 06-17-08 02:57 PM

I'm not so sure about that Seerah. I carried out my own complete reinstall via WAU not that long ago WITHOUT externals and the appropriate libraries downloaded and installed right along side. Does the same on updates as far as I can tell. At least for me it does.

It does sound like there are no libraries there though, so I would go along with what Seerah says.

Seerah 06-17-08 05:51 PM


Originally Posted by Arabeth (Post 93840)
I'm not so sure about that Seerah. I carried out my own complete reinstall via WAU not that long ago WITHOUT externals and the appropriate libraries downloaded and installed right along side.

You had "Automatic Dependency Download" enabled.

tiph49 07-30-08 04:37 AM

Missing Dependicies!
I've done everything by the book to get my auctioneer add-on and it's supposed to work but it says it won't work because of missing dependincies!
The missing dependincies are: EhnToolTip and Stubby.
Could somebody guide me towards the solution?

Mera 07-30-08 04:44 AM


Originally Posted by tiph49 (Post 97030)
I've done everything by the book to get my auctioneer add-on and it's supposed to work but it says it won't work because of missing dependincies!
The missing dependincies are: EhnToolTip and Stubby.
Could somebody guide me towards the solution?

Yes simple download the full pack with dependencies directly from the homepage

check back this page regulary for updates

tiph49 07-30-08 05:28 AM

Still Problems...
This what I've done:

- Downloaded program from requested link
- Moved downloaded files from bitcomet to desktop
- Extracted zip files (On desktop)
- Copied extracted files and moved to WoW add-ons folder

Mera 07-30-08 06:19 AM


Originally Posted by tiph49 (Post 97034)
This what I've done:

- Downloaded program from requested link
- Moved downloaded files from bitcomet to desktop
- Extracted zip files (On desktop)
- Copied extracted files and moved to WoW add-ons folder

and still having issue? majke sure you have EnhTooltip and Stubby folders inside your wow\interface\addons\* dir, and on the characters selection page click the addon button and make sure both are checked nor maybe you have an ingame management addon like ACP preventing them to load ?

tiph49 07-30-08 06:31 AM

I have all the requirements but now the add-ons button at character selection is gone!

Mera 07-30-08 06:58 AM

your problem must be linked to that error because the add-ons button must be there on the characters selection page, bottom corner left exactly. If I remember the add-on button does not display if 0 addons are detected, are you sure you have dirs that loooks like this with auctioneer?


D:\Games\World of Warcraft\Interface\AddOns\Auc-Advanced\*all files
D:\Games\World of Warcraft\Interface\AddOns\EnhTooltip\*all files
D:\Games\World of Warcraft\Interface\AddOns\Stubby\*all files

tiph49 07-30-08 07:12 AM

This is an example of EhnToolTip:
C:\Program Files\World of Warcraft\Interface\AddOns\AuctioneerAdvancedSuite-5.0.PRE.3262\EnhTooltip
Stubby is the same...

Mera 07-30-08 07:35 AM


Originally Posted by tiph49 (Post 97045)
This is an example of EhnToolTip:
C:\Program Files\World of Warcraft\Interface\AddOns\AuctioneerAdvancedSuite-5.0.PRE.3262\EnhTooltip
Stubby is the same...

lol and you still dont see what is wrong ? ;) it must be

C:\Program Files\World of Warcraft\Interface\AddOns\EnhTooltip

This is bcuz of the AuctioneerAdvancedSuite-5.0.PRE.3262 folder which has nothing to do there it fails to detects

you must have something that looks like this


C:\Program Files\World of Warcraft\Interface\AddOns\Auc-Advanced
C:\Program Files\World of Warcraft\Interface\AddOns\Auc-ScanData
C:\Program Files\World of Warcraft\Interface\AddOns\BeanCounter
C:\Program Files\World of Warcraft\Interface\AddOns\EnhTooltip
C:\Program Files\World of Warcraft\Interface\AddOns\Stubby

the same for any addon, you should always leave the directory the mod author created to the base C:\Program Files\World of Warcraft\Interface\AddOns\, you shouldn't add extra folders up to this. I guess AuctioneerAdvancedSuite-5.0.PRE.3262 has been created by your file extractor which often auto create folder based on the archive name.

tiph49 07-30-08 07:43 AM

Could you give me bit-by-bit instructions to get it working?
I'm not great with computers... :D

Mera 07-30-08 08:01 AM

you can see that on curse.Com , look for example my addon page, at the middle where there is the description of my addon there is a Tab called "Install Guide", this is a standard guide displayed on every addon page on curse to learn how to install addon if that is your first use, look here , middle screen click "Install Guide" and read carefully each steps.

Seerah 07-30-08 09:14 AM

There are instructions in the first post of this thread, there is a guide with screenshots in our FAQ linked at the top of every page, and there is a video walkthrough linked in the first post of the thread as well.

tiph49 07-31-08 04:29 AM

I downloaded the guide and I left it for a day and now that I've come back to it... I don't know how to work the guide! :confused:

tiph49 07-31-08 04:33 AM

I have...
-Downloaded files from requested site to bitcomet
-Extracted the files to my desktop
-Opened the files and now I can't read it, I don't know what to do

Mera 07-31-08 04:40 AM


Originally Posted by tiph49 (Post 97117)
I downloaded the guide and I left it for a day and now that I've come back to it... I don't know how to work the guide! :confused:

can't help you much me already told you all.. I give up.

Cairenn 07-31-08 05:10 AM


Originally Posted by tiph49 (Post 97118)
-Downloaded files from requested site to bitcomet

Huh? I have absolutely no idea what you are saying here. What have you downloaded from where? Link to the page you are trying to download from, please.

tophero21 07-31-08 06:09 AM

think he means he downloaded directly from the auctioneer site using bitcomet (a program to dl torrents) and has extracted the zip file to his desktop.

since I don't use auctioneer, I can't say exactly what's in that zip file, but I'm assuming he's extracting everything to a folder named the same thing as the zip file. all he should have to do is go into that folder and grab the auctioneer/stubby/enhtooltip/etc folders and copy them into his addons directory.

tiph49 07-31-08 06:22 AM

Do I post each file individualy or in the auctioneer file?

Typhanie0483 07-31-08 06:30 AM

not able to get add ons
I am making sure that I go through C:/Programs Files/WOW/interface/addons. Once I have the add on up I clicked open and put it in the file. Then I seen the forum that said to save instead. I have done it both ways and I am still not getting the add on button in WOW. I have been trying to get addons since new patch. Can someone please help?

tophero21 07-31-08 07:04 AM

geez, this is a mess, and not what I think Seerah was intending when starting the thread...

anyway, to make this easier I actually went to the auctioneer page and grabbed the zip file, so we will start from there.

1. take the .zip file and copy-paste it into your c:/program files/world of warcraft/interface/addons folder (or re-download and save it there directly).

2. right click on the .zip file and choose to "Extract here", either from the 7zip, Winzip, or Winrar options

3. the following folders should appear:

4. fire up WoW, addons button should show up with each of the above listed

Seerah 07-31-08 10:02 AM

Thank you, Topher.

Yes, a new folder is being created for tiph49, as they had already mentioned the folder name and was already told what was wrong and how to fix it. If you still have troubles, tiph49, please look at the FAQ with the screenshots and/or watch the video.

snowdancer7 08-01-08 11:10 AM

I seem to be getting an "Internal Error" during the backup process when trying to install an addon through the UI Manager.

I have created the "Interface/AddOns" directoies and placed my extracted addon files in there (QuestHelper, to be specific). I was not getting an Add On button, so went to try the UI Manager Then I go to register it in the UI Manager, enter the ID from the URL (which is actually a forum topic; how else do I get it?), and follow the steps in the interface. However, when it begins the update, it comes up with an Internal Error almost immediately.

Please tell me these addons are worth all this! :(

tiph49 09-30-08 09:09 AM

Thanks for the help, guys!
I was able to get the files working after using winzip. The Auctionerr Add-On still didn't work but I'm using QuestHelper which works great! Thanks for putting in the effort! :banana:

pawprint45 10-17-08 09:26 AM

I downloaded the updated version of auctioneer. It doesn't have an auctioneer folder like the old version or at least it didn't download as part of the zip file. I have not been able to get the suite to work at all, even though I deleted the old auctioneer before installing the latest version. It's installed to my interface/addons folder like the rest of my addons. Any suggestions?

Seerah 10-17-08 10:25 AM

First, please don't double-post. :p

Second, did you ensure that you have it installed correctly, ie, no folder-in-folder syndrome? There should be several folders for Auctioneer and its dependencies. Unless you mean something else by "it does not work" which is vague?

pawprint45 10-17-08 11:22 AM

The addon is in my worldofwarcraft/interface/addons folder, just like my other addons. My auctioneer folder is red (showing out of date at addons button on character screen) but the rest of the auctioneer-related files are fine. Only the 3 tabs from Blizzard are showing when I'm at AH. Tooltip isn't working. I don't get the auctioneer loaded message when I log into game on my character. Any ideas? It's the latest version.

Seerah 10-17-08 12:46 PM

Did you click load out of date addons?

talisen82 10-19-08 03:27 PM

I also have trouble installing Auctioneer Suite.

I've done all the steps installed the same way as every other addon.
(I use Qhelper, Lightheaded and Tom Tom) But i didn't get it to work.

Since i am an Vista user, i disabled UAC, Moved the Wow folder to C:\Games\World of warcraft. I even tried to set authentication to the highest (wich i didn't have to do because UAC is turned off)

This is how it is;

There is nothing wrong here is it? so why isn't it working??


Forgot to mention that the addon doesn't appear under the addon button, so there isn't anything to check off. While Qhelper, LH and tom tom are there

Seerah 10-19-08 03:55 PM

We need to see where your .toc file is. Also, do you only have one install of wow? Is your launcher/shortcut pointed to the correct directory, if you have two copies?

talisen82 10-19-08 06:07 PM

ok you lost me at .toc :confused: I dont recognize this extension

I only have one copy of the wow file and just replaced it from program files to c:\games (i created this path) I did this after i tried everything i could while it was in program files.

Normaly this should work but it doesn't, weirdly enough.

So the question is where can i find the .toc file so i can show it.

Seerah 10-19-08 06:42 PM

Inside the addon's folder. Screenshots are in the FAQ here:

talisen82 10-20-08 04:09 AM

According to the screenshots, i've done this correctly.

Here is how it is, this example is the same for every folder;

Really i don't understand what wrong. Could it be the Auctioneer suite itself?

Seerah 10-20-08 09:27 AM

Are you getting any errors? Make sure that you aren't hiding lua errors in your Interface Options.

Evolution85 10-20-08 09:34 AM

Great post Seerah! Guide is very nicely done!

talisen82 10-20-08 02:46 PM


Originally Posted by Seerah (Post 105694)
Are you getting any errors? Make sure that you aren't hiding lua errors in your Interface Options.

No errors. Auctioneer suite isn't even under the add-on tab. not Ingame in the interface or on the char select page. So its safe to say Auctioneer suite isn't even being loaded into WoW.

Btw I appreciate you taking the time to help me ;)

Do you know of a different mirror to download the zipfile? If you do than i'll try that first.

talisen82 11-13-08 12:44 PM

AddOn button is gone
Hey guys,

WOTLK messed up my addon options as in there are none!!

The addon button disappeared.

Here are the steps i followed to get it back.

I removed all the folders inside the addon folder and downloaded all of the files again through wow interface. That is; Questhelper, Tom Tom and lightheaded.

Normaly i would have to check the "load out of date data" box but i don't get an addon button on the char select page.

PLZ help me

Seerah 11-13-08 01:34 PM

Did you double-check that they were extracted correctly?

Post the file path to LightHeaded.toc

talisen82 11-14-08 07:41 AM

Extracted correctly, but i think it is a Vista problem. Where could i send an patch request if neccecary?
On my brothers pc it works with XP.

Here is the path to lightheaded.toc

BTW; Would Wow Work on LINUX?? Than i could install it on my PS3.

All times are GMT -6. The time now is 02:26 AM.

vBulletin © 2021, Jelsoft Enterprises Ltd
© 2004 - 2020 MMOUI