WoWInterface (
-   AddOn Help/Support (
-   -   Having trouble installing addons? (

Seerah 01-30-08 11:34 AM

Having trouble installing addons?
Do you want to start using addons, but can't seem to get them installed correctly?
Do your friends keep telling you that you need to try a mod, but you just can't wrap your head around how to do it?

There are many places for you to look for help.

This site has a great FAQ for installing mods. You can always find it again by clicking the "Help & F.A.Q." link up at the top of every page on the site.

If you use Vista, there are some peculiarities with Vista's security/permissions that can make it difficult and confusing. Read through Shirik's Vista Users - UAC and You sticky in this forum. More help on Vista can be found in the official WoW Tech Support forum. Also, make sure you are installing the addons to the correct location. With a recent patch, WoW would have asked you if you would like to move the game out of the Program Files directory. If you answered "yes", your WoW folder is now located at C:\Users\Games\World of Warcraft. This is the directory you need to install to. Anything left at C:\Program Files\World of Warcraft can be deleted.

If you use a Mac, then check out the Mac Support forum on the WoW site. (Though addons are platform independent.)

There are a lot of guides and videos around the net to help you as well. Here's one that I made.

The UI & Macros forum on the WoW site can be a great help as well. Here is a guide written by Lopeppeppy (edited by Troodi and Unkle) that is plastered all over that forum.


Where is my addons menu!!? Lopeppeppy's Guide on Mod Installation

If the button doesn't appear on the WoW interface it's because the mods aren't installed correctly, (or alternatively, none installed at all).

1. Make sure you only have one copy of WoW installed and addons are in the correct directory. After a reinstall there is the possibility of having two or more copies of WoW on the same system and the addons have been inserted into the wrong folder. This is also common for Windiws Vista users as Patch 3.0.2 or the WotLK installer ask to move your WoW to a non-protected folder.

● Using Repair Tool: When the repair tool is run the Interface and WTF folders get renamed with the date added to the file name. This means those addons won't get loaded.

2. Make sure you are unzipping/uncompressing your addons. WinZip, WinRar, 7zip and StuffIt (for Mac) are common unzipping programs. WinZIP users: You MUST make sure the option to "Use Folder Names" is CHECKED or it will just extract the files and not make the proper folders as per the mod Authors structured directory paths.

3. Make sure that you aren't installing addons while WoW is running. WoW doesn't register addon changes until you logout and then back in, so save yourself some frustration and install while logged out and WoW is not running. Log in to check them, log back out as necessary to fix things.

4. Check the "Load Out of Date Addons" button on your Addons screen (when you install them properly, or if you already have some installed).

5. If using Windows VISTA see this article:

How-To: Trouble-Shoot AddOns under Vista by Lunessa/Unkle:

6. For Mac Users: Check spelling. Make sure the AddOns folder is named and matches exactly the capital letters and spelling to be: AddOns (The "O" is a capital letter and not the number zero "0")

● Some other things to check ●

The most common error is that the unzipper program embedded them into an extra folder layer. If you have any questions about whether your addons are embedded one folder too deep, post a path for the .toc file of each addon

Windows XP:
C: \Program Files\World of Warcraft\Interface\AddOns\MODFolder\ModName.toc

Windows Vista:
C: \users\public\games\World of Warcraft\World of Warcraft\Interface\AddOns\MODFolder \ ModName.toc

INCORRECT EXAMPLE (the addons will not load properly.):
Windows XP/Vista:
..\World of Warcraft \Interface\AddOns\MODFolder1.23.456\MODFolder\ModName.toc

Mac OSX:
../World of Warcraft/Interface/AddOns/MODFolder1.23.456/MODFolder/ModName.toc

There should only be one path-step between the AddOns step and the .toc step, and it should be the name of the addon (most usually). Look very closely at the directory structure, make sure that the addon's folder is in the proper place.

Standard Interface Guide

Excellent FAQ

Sample screen of file directory structure (Macs have same basic structure, though some minor differences)

WoW Addon Install Tutorial Nice video by Seerah.


* * * *

If all else fails, just ask any questions you have. Remember, all you have to do to get rid of those mods is delete the Interface folder. The Blizzard mods inside will be recreated the next time you start the game.

obedwon 03-26-08 10:10 PM

add on helplz
Why dont i have a add on tab on my character screen??

Seerah 03-26-08 10:58 PM

Did you follow all of the guides and instructions provided?

rkb5 03-29-08 09:37 AM

hi, iv got the correct pathways for my addons as per the instructions on this website but i still have no addons button on my screen, i have noticed that if u click the addon my computer says that it doesnt recognize it & shud it use the internet to find a programme to run it - i clicked yes bt all it said was that it was an unknown file & to combat this i shud contact sum1 to find out wot programme i shud use.
can sum1 help me out plz? all i wanted was map co-ords! :(

Arabeth 03-29-08 10:11 AM

Sounds like you are clicking directly on the *.lua file that is included in the addon's folder.

This is not a file that runs in Windows. WoW effectively incorporates this file into the game and the game uses it to produce whatever effect the programmer was intending (usually :-)).

Your addon file structure should be something like...

C:\World of Warcraft\Interface\Addons\YourNewAddonFolder

Unless there is a problem with your system in that it cannot access the files in that directory, WoW should read the file.

There is a difference between the operating system allowing access to files and the program (WoW) interpreting the data (code) within it. Your operating system has a layer(s) of security that could prevent a user access to the file, which would prevent any application doing so.

Gemini_II 03-29-08 12:44 PM

Click on Seerah's video. You need to install WinZip or WinRAR.

Seerah 03-29-08 05:42 PM

Windows has an extraction utility - at least XP and Vista do...

Gemini_II 03-30-08 12:14 AM

True. Been too long since using it to remember, lol.
The OP must be trying to open the addon files themselves then. In which case refer back to Seerah's video. :)

flaviu tomuta 04-14-08 08:29 PM

Quick question??
How do i use two different UI's for two different characters??

Seerah 04-14-08 09:07 PM

Two different UI compilations? The easiest way is to have two separate Interface and WTF folders, renaming them depending on which character you're using. But you'll have to completely exit the game when changing characters. The other way is to use different profiles in your mods for each character.

eyehatehippies 04-26-08 04:02 PM

I followed the instructions to the letter on how to install. Made sure i only had 1 WoW directory. Made sure there was only 1 folder with add-on's name on it., etc. Extracted the files using WinZip 10.0, and it's still doing nothing. A little help?

Seerah 04-26-08 08:08 PM

It would help if you gave more information. Like what OS you're on, what addon you're trying to install, and what "it's still doing nothing" means exactly. ;)

Tman21 05-21-08 06:03 PM

yeah im trying to install Atlas Cartagrapher and Lightheaded. I put them in the addon folder extract them but nothing happens.

Seerah 05-21-08 08:03 PM

Did you watch the video and/or look at the pictures in the FAQ to make sure that you're doing it correctly? Give the full path to the LightHeaded.toc file.

Gemini_II 05-21-08 11:49 PM

Or post a screenshot of your folders :)

Tman21 05-22-08 04:15 PM

how do you take a screenshot? i have a bunch of other folders in my addon like Blizzard_Auction UI are those supposed to be there or somewhere else? here is the link for the lightheaded i downloaded

Tman21 05-22-08 04:30 PM

hey nvm i got it. thx for the help you guys :D:banana:

loganz 06-10-08 02:25 AM

Help meh out?
everytime i download an addon it pops up a thing that says open save close.
i click open and it goes to my folders and when i try to go to WoW and click the addon button it doesn't show the addon i downloaded only shows my other i downloaded from a diff site why wont it show the addon i downloaded here?

Seerah 06-10-08 07:41 PM

Don't click "Open". Click "Save".

Mithessar 06-17-08 01:04 PM

Add-ons installed, invisible in-game
Hey folks,

I just reinstalled WoW on a new hard drive - it all went smoothly until I tried to reinstall my add-ons. I'm running Windows xp pro on a Compaq nc8430 laptop. Here's what I've got:

Using WoW Ace, I downloaded/installed Cartographer, Omen, DrDamage, and Quartz into the following path:
C:\Program Files\World of Warcraft\Interface\Addons\[addon-name] for example,
C:\Program Files\World of Warcraft\Interface\Addons\DrDamage\DrDamage.toc

The good:
When I log in to WoW, I see the addons button on the bottom left of the character selections screen. They all appear to be functional/updated, and I can activate different addons for different characters.

The bad:
When I select a character and enter the game, I see no addons. I do not see the addon manager around the minimap, and commands such as /omen do nothing. Looking through every interface/graphics option I can find, I can see no way to access the supposedly enabled add-ons.

What I've tried:
Restarting WoW
Deleting & reinstalling add-ons
Disabling & re-enabling addons
Logging in with different characters

Obviously, it'd be really great to get this working soon; it's hard to raid without a threat meter! Thanks much,


All times are GMT -6. The time now is 12:55 AM.

vBulletin © 2021, Jelsoft Enterprises Ltd
© 2004 - 2020 MMOUI