Results: 77Comments by: ywfn
File: Examiner12-21-14
One more thing I noticed, when tryi...
Posted By: ywfn
One more thing I noticed, when trying to inspect certain NPCs: Examiner\core.lua:850: attempt to concatenate field 'raceFixed' (a nil value) Examiner\core.lua:850: in function `UpdateObjects' Examiner\core.lua:700: in function `DoInspect' :4: in function <:1>
File: TipTac12-21-14
I noticed the AnchorType on the too...
Posted By: ywfn
I noticed the AnchorType on the tooltips for the Garrison missions was: "ANCHOR_CURSOR_RIGHT". TipTac has 2 checks for "ANCHOR_CURSOR", but none for that. I changed this line in GTTHook_OnShow: if (gtt_anchorType == "mouse") and (string.sub(self:GetAnchorType(), 1, 13) ~= "ANCHOR_CURSOR") then And just for good measure, also...
File: TipTac12-21-14
Also of interest, when you first mo...
Posted By: ywfn
Also of interest, when you first move onto the frame with the tooltip (before moving the mouse to stretch it), you see this: http://i.imgur.com/d42Vubs.jpg (That's with Frame Tip Type set to mouse anchor, and the point set to bottom right It's like the right side of the tooltip is being anchored at bottom right (as configured), but...
File: TipTac12-20-14
Yep, I see it. If you set Frame Ti...
Posted By: ywfn
Yep, I see it. If you set Frame Tip Type to Mouse Anchor, then it only works right if you also set the Frame Tip Point to Center. Everything else gives you the tooltip stretching that follows the mouse (or sometimes "inside-out" tooltips if your mouse is in the wrong place relative to the Garrison Mission frame with the tooltip...)
File: Examiner12-20-14
Yep, the changes in WoD are huge....
Posted By: ywfn
Yep, the changes in WoD are huge. But the game is better than ever. Obviously you should play again!
File: Examiner12-20-14
Also, no more distinction on gear b...
Posted By: ywfn
Also, no more distinction on gear between melee/spell crit and haste as far as I know. I think it would make the most sense to break it down like this: Base Stats = Stam, Int/Agi/Str, Armor (include Bonus Armor in the Armor value? Technically "Bonus Armor" is a secondary, but it just adds to your Armor obviously) Secondaries =...
File: Examiner12-20-14
Yeah, maybe there is no way for the...
Posted By: ywfn
Yeah, maybe there is no way for the BoA thing. I see that this library has a GetHeirloomTrueLevel() function, but it achieves it by actually scanning the tooltip: http://www.wowace.com/addons/libitemupgradeinfo-1-0/ Regarding the other items: * The ratings/percentage thing will never be correct again (at any player level, as...
File: Examiner12-20-14
In 6.0, the Examiner config screen...
Posted By: ywfn
In 6.0, the Examiner config screen is no longer working properly because apparently the return values from GetChecked() have changed to where they are now true or false. So the "nil" on this line in config.lua needs changing to "false": cfg = (self:GetChecked() ~= nil); Also, as someone mentioned on Curse, BoA's that scale up...
File: TipTac12-20-14
The cursor "drags" the tooltip back...
Posted By: ywfn
The cursor "drags" the tooltip backdrop in the "Active Missions" tab. I took some screenshots. This first one is just dragging the mouse pointer over a mission. Without moving the pointer at all, the tooltip backdrop is just a single line with the content to the side. http://i.imgur.com/WI9nvlE.jpg Dragging the pointer to the...
File: TipTac12-04-14
I don't think it's really true that...
Posted By: ywfn
I don't think it's really true that there are a lot of issues. The ones that seem legit that I've seen mentioned here or Curse are: * Disappearing world tooltips. The people who get this (I've never seen it myself so it's not something that affects everyone) also get it even without TipTac running, so it's not a TipTac thing. *...
File: TipTac11-23-14
A new issue that has been showing u...
Posted By: ywfn
A new issue that has been showing up in many places in WoD is that many NPCs apparently have titles that are " " (a single space). As an example: http://i.imgur.com/OQyA8Ri.jpg The game's default tooltip ignores these empty titles, and I've modified TipTac\core.lua to eliminate the problem. I'll link my fixed file below for anyo...
File: TipTac10-23-14
Am I the only one getting a - sign...
Posted By: ywfn
Am I the only one getting a - sign as opposed to a + sign for stats? all my gear is showing -crit ect ect for stats. disable tiptac and all looks fine, just a minor nuisance :p didn't notice it until I was setting up my UI for my mage, thought bliz was trolling me lol :banana: Haven't seen it. I don't think TipTac even changes that...
File: TipTac10-22-14
That error isn't even coming from T...
Posted By: ywfn
That error isn't even coming from TipTac, it's coming from something called "SVUI". Probably caused by some kind of interaction between SVUI and TipTac. You'll probably find that if you disable "SVUI", you'll stop getting the error as well.
File: TipTac10-22-14
Just a question, what is your Fadin...
Posted By: ywfn
Just a question, what is your Fading options for TipTac? Are you overriding the fading, and what are your fade timings? I always ran with zero fade, which may be why it was always harder for me to detect these issues, as I never encountered them daily. Just checked on this: Override is turned on Pre-fade is 0.6 secs Fadeout is 0....
File: TipTac10-22-14
Re: Lag
Posted By: ywfn
I downloaded the new version and every time I mouse over an NPC or target an NPC I lag. My whole game freezes for a second. I disabled all my addons and went one by one...Tiptac is the culprit. Any suggestions? Post what version you're running and also make sure you have Display Lua errors turned on (in the game's Interface->Help...
File: TipTac10-21-14
Servers are down for maintenance, s...
Posted By: ywfn
Servers are down for maintenance, so I can't check at the moment, but I want to say that my tooltips fade out over the course of 1-2 seconds. And I'm not doing anything special outside of the options that TipTac itself offers. If you don't use fade, I believe you wouldn't ever see this problem (meaning #1 that I listed below, not s...
File: TipTac10-19-14
Also there seems to be a problem wh...
Posted By: ywfn
Also there seems to be a problem where tooltips stop showing up at all, without any error. Don't have any more details about that, sadly. I've never seen that one myself. But I did look into the color problems and found out there's kinda two separate problems: (1) When jumping from tooltip-to-tooltip (ie, not allowing a full fad...
File: TipTac10-18-14
Was wrong in my last post, there is...
Posted By: ywfn
Was wrong in my last post, there is an issue with the background/backdrop too, not just the border. If I move straight from an NPC/player tooltip to a mailbox or portal or whatever (not allowing for a fade-out inbetween), the background is the wrong color as well as the border.
File: TipTac10-17-14
Quite possibly related to Stanzilla...
Posted By: ywfn
Quite possibly related to Stanzilla's comment, but I've noticed now that if I mouseover a player (I have player tips set to color the border based on class), then if I mouse over something like a mailbox next, the mailbox's tooltip has the same colored border as the last player I moused over. Backdrop colors do not carry over in thi...
File: Examiner05-21-14
Yep, that works. Same fix can be a...
Posted By: ywfn
Yep, that works. Same fix can be applied to TipTac's TipTacItemRef\GetUpgradedItemLevel.lua as well.
File: Examiner05-20-14
The new 5.4.8 patch now allows you...
Posted By: ywfn
The new 5.4.8 patch now allows you to upgrade items 4 times instead of 2. So, items that were previously 2/2 (+8 ilvls) are now 2/4, and can be upgraded to 4/4 (+16 ilvls). I did an item link dump of one item while it was 2/4 (ilvl 580), 3/4 (ilvl 584), and then 4/4 (ilvl 588): http://i.imgur.com/ULuuAFc.jpg Let me know if yo...
File: Examiner02-06-14
ywfn Whoa, you're fast, or maybe y...
Posted By: ywfn
ywfn Whoa, you're fast, or maybe you had everything prepared already? If you'd like you can release the module by yourself, or do you want me to include it into Examiner? I'm curious, what does the official Blizzard PvP frame look like these days? Nah, didn't have anything prepared, guess I'm just fast :) Here's what the Blizz...
File: Examiner02-03-14
I revised pvp.lua to strip out all...
Posted By: ywfn
I revised pvp.lua to strip out all the obsolete stuff and create a new display for the ratings/wins, patterned after the way honor is displayed. The result looks like this: http://i.imgur.com/oNDElXI.jpg Everything seems to work great so far, including caching. My new pvp.lua is here: http://pastebin.com/FLRwRAyx If you are wil...
File: Examiner02-03-14
Well, nowadays the builtin WoW insp...
Posted By: ywfn
Well, nowadays the builtin WoW inspect shows you only 8 pieces of data in the PvP tab... Rating and Wins for 4 brackets: 2v2, 3v3, 5v5, and Rated Battlegrounds. Getting the info is pretty simple, after the RequestInspectHonorData() (which Examiner already does I believe) is complete, just use GetInspectArenaData(x), where x = 1 for...
File: TipTac10-05-13
Tried your config, and don't have t...
Posted By: ywfn
Tried your config, and don't have the problem, everything looks fine. Have you tried disabling all other addons besides TipTac to see if something else is causing it?