Minion Beta! - Help us test our new AddOn updater. Get it now!
Download
(51 Kb)
Download
Updated: 05-02-11 05:36 PM
Addon for:
AtlasLoot Enhanced.
Pictures
File Info
Updated:05-02-11 05:36 PM
Created:03-19-09 10:30 PM
Downloads:96,331
Favorites:672
MD5:
AtlasLootReverse  Popular! (More than 5000 hits)
Version: 1.15
by: pceric [More]
Adds a line to an item's tooltip showing who drops it and where. Uses AtlasLoot Enhanced data and therefore requires ALE v6 to be installed and enabled.

Type /alr for options.
1.15 - Fix for missing boss names in ALE 6.03.01

1.14 - Update TOC for 4.1
- Workaround for broken module loading in ALE 6.03

1.13 - Library updates.

1.12 - Update tooltip library again.
- Fix for ALE 6.02

1.11 - Fix possible taint issue with tooltip library.
- Fix for more missing items.

1.10 - Fixed missing items.
- Add some excludes for tokens & shards.

1.9 - Really fixed for new versions of ALE.

1.8 - TOC updated for 4.0.
- Libraries updated.
- Fix for new versions of A.L.E.

1.7 - TOC updated for 3.3.
- Tooltip library update.
- Additional filtering.

1.6 - Fix giant profile bug (Delete your AtlasLootReverse.lua SavedVariables file).
- Few other minor changes.

1.5 - Updated libraries.
- TOC updated for 3.2.

1.4 - Now shows if an item drops from multiple sources.
- Some simple filtering to make source read a little better.
- Can now toggle embedded tooltip with /alr embed

1.3 - Bumped versions.
- Updated libs.

1.2 - Now works with chat-linked tooltips.
- Better handling of 25 man loot.
- New DB format uses less memory.

1.1 - Fix bug that screws up Auctioneer tooltip.
- Minor text cleanup.

1.0 - Initial release
Archived Files (15)
File Name
Version
Size
Author
Date
1.14
51kB
pceric
04-30-11 02:35 PM
1.13
51kB
pceric
03-15-11 09:08 PM
1.12
50kB
pceric
01-30-11 09:05 PM
1.11
50kB
pceric
12-18-10 08:08 PM
1.10
50kB
pceric
12-15-10 01:20 AM
1.9
50kB
pceric
12-15-10 12:31 AM
1.8
50kB
pceric
12-11-10 03:26 PM
1.7
49kB
pceric
12-09-09 01:13 AM
1.6
49kB
pceric
08-14-09 06:13 PM
1.5
49kB
pceric
08-09-09 01:23 PM
1.4
48kB
pceric
05-13-09 08:22 PM
1.3
44kB
pceric
04-15-09 11:02 PM
1.2
42kB
pceric
03-20-09 11:49 PM
1.1
42kB
pceric
03-19-09 11:04 PM
1.0
42kB
pceric
03-19-09 10:30 PM


Post A Reply Comment Options
Unread 12-10-11, 04:02 PM  
tobindax
A Cyclonian
AddOn Author - Click to view AddOns

Forum posts: 47
File comments: 19
Uploads: 2
Re: Update

Originally Posted by Hegarol
Hey guys

for all of you looking for an update to this addon.
The AtlasLoot team now provides an official addon with the same functionality.

http://www.wowinterface.com/download...t_Tooltip.html

I talked to pceric and he said he isn't really active right now, so AtlasLoot_Tooltip is the successor to AtlasLootReverse.

Have fun with it
I'm sorry but this is very incomplete. It does not include several items and as of today it doesn't even find the valor rewards.

AtlasLootReverse still works.
tobindax is offline Report comment to moderator  
Reply With Quote
Unread 10-05-11, 03:00 AM  
Hegarol
A Fallenroot Satyr
AddOn Author - Click to view AddOns

Forum posts: 20
File comments: 127
Uploads: 2
Update

Hey guys

for all of you looking for an update to this addon.
The AtlasLoot team now provides an official addon with the same functionality.

http://www.wowinterface.com/download...t_Tooltip.html

I talked to pceric and he said he isn't really active right now, so AtlasLoot_Tooltip is the successor to AtlasLootReverse.

Have fun with it
__________________
Project Lead AtlasLoot
http://www.atlasloot.net
Twitter:http://twitter.com/Atlasloot
Hegarol is offline Report comment to moderator  
Reply With Quote
Unread 05-10-11, 05:29 AM  
tobindax
A Cyclonian
AddOn Author - Click to view AddOns

Forum posts: 47
File comments: 19
Uploads: 2
Feature that would make this amazing:

Show mats when hovering over a flask or by ctrl clicking or similar
Last edited by tobindax : 05-10-11 at 05:30 AM.
tobindax is offline Report comment to moderator  
Reply With Quote
Unread 05-02-11, 05:37 PM  
pceric
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 38
Uploads: 0
Originally posted by sykopat
I get this error after latest atlasloot update:

Date: 2011-05-02 20:35:16
ID: 3
Error occured in: Global
Count: 1
Message: ...terface\AddOns\AtlasLootReverse\AtlasLootReverse.lua line 132:
attempt to concatenate field 'name' (a nil value)
Debug:
(tail call): ?
...terface\AddOns\AtlasLootReverse\AtlasLootReverse.lua:132:
...terface\AddOns\AtlasLootReverse\AtlasLootReverse.lua:60
(tail call): ?
[C]: ?
[string "safecall Dispatcher[1]"]:9:
[string "safecall Dispatcher[1]"]:5
(tail call): ?
...\AtlasLoot_Loader\Libs\AceAddon-3.0\AceAddon-3.0.lua:543: EnableAddon()
...\AtlasLoot_Loader\Libs\AceAddon-3.0\AceAddon-3.0.lua:635:
...\AtlasLoot_Loader\Libs\AceAddon-3.0\AceAddon-3.0.lua:621
[C]: LoadAddOn()
..\FrameXML\UIParent.lua:256: UIParentLoadAddOn()
..\FrameXML\UIParent.lua:330: TimeManager_LoadUI()
..\FrameXML\UIParent.lua:544:
..\FrameXML\UIParent.lua:519

<snip>

AtlasLoot, vv6.03.01
AtlasLootBurningCrusade, vv6.03.01
AtlasLootCataclysm, vv6.03.01
AtlasLootClassicWoW, vv6.03.01
AtlasLootCrafting, vv6.03.01
AtlasLootLoader, vv6.03.01
AtlasLootWorldEvents, vv6.03.01
AtlasLootWrathoftheLichKing, vv6.03.01
AtlasLootAdvancedSearch, vv1.2.8
AtlasLootReverse, v1.14

<snip>
Looks like the new ALE 6.03.01 is missing some boss names. I've pushed a new version with a workaround.
pceric is offline Report comment to moderator  
Reply With Quote
Unread 05-02-11, 12:41 PM  
sykopat
A Kobold Labourer

Forum posts: 1
File comments: 19
Uploads: 0
I get this error after latest atlasloot update:

Date: 2011-05-02 20:35:16
ID: 3
Error occured in: Global
Count: 1
Message: ...terface\AddOns\AtlasLootReverse\AtlasLootReverse.lua line 132:
attempt to concatenate field 'name' (a nil value)
Debug:
(tail call): ?
...terface\AddOns\AtlasLootReverse\AtlasLootReverse.lua:132:
...terface\AddOns\AtlasLootReverse\AtlasLootReverse.lua:60
(tail call): ?
[C]: ?
[string "safecall Dispatcher[1]"]:9:
[string "safecall Dispatcher[1]"]:5
(tail call): ?
...\AtlasLoot_Loader\Libs\AceAddon-3.0\AceAddon-3.0.lua:543: EnableAddon()
...\AtlasLoot_Loader\Libs\AceAddon-3.0\AceAddon-3.0.lua:635:
...\AtlasLoot_Loader\Libs\AceAddon-3.0\AceAddon-3.0.lua:621
[C]: LoadAddOn()
..\FrameXML\UIParent.lua:256: UIParentLoadAddOn()
..\FrameXML\UIParent.lua:330: TimeManager_LoadUI()
..\FrameXML\UIParent.lua:544:
..\FrameXML\UIParent.lua:519

<snip>

AtlasLoot, vv6.03.01
AtlasLootBurningCrusade, vv6.03.01
AtlasLootCataclysm, vv6.03.01
AtlasLootClassicWoW, vv6.03.01
AtlasLootCrafting, vv6.03.01
AtlasLootLoader, vv6.03.01
AtlasLootWorldEvents, vv6.03.01
AtlasLootWrathoftheLichKing, vv6.03.01
AtlasLootAdvancedSearch, vv1.2.8
AtlasLootReverse, v1.14

<snip>
sykopat is offline Report comment to moderator  
Reply With Quote
Unread 04-14-11, 04:00 PM  
jmcgrath
A Kobold Labourer
 
jmcgrath's Avatar

Forum posts: 0
File comments: 189
Uploads: 0
Re: I think I got it! :)

Originally posted by kyky123
I was having the same issue and I may have figured out how to fix it. Although, I tried about 3 things, so maybe only one really works, but I'll let you know what I did.

I'm running the 6.03 beta version of AltasLoot Enhanced. And AtlasLootReverse hasn't worked for me since about 2 versions prior. Finally I went through my old settings. WTF/Account/"YOUR ACCOUNT NAME"/.... and from here I went under each of my characters and deleted the "AddOns.txt" files and then I made sure to delete any *.lua and *.lua.bak files associated with Atlas (of any version) and any unused addons. I don't recall any of this working until I went under the "Saved Variables" folder and deleted ALL of the *.lua and *.lua.bak files associated with Altas anything though, so maybe that is really the trick. Then I REINSTALLED AtlasLootReverse. (Since I realized that I deleted the reference file for this to work previously <.< oops. Should be larger than a few KB in size - mine is 778KB)

After all of my tedious fidgeting with these files, I restarted WoW again and this time it worked (there should be a message in your chat window about recompiling the dataset for AtlasLoot Reverse or something of that nature).

I had previously deleted these files for individual characters and it hadn't worked at all, so it's possible the combination of things made it so. But after deleting any *.lua & *.lua.bak files, you have to make sure to reinstall this addon so that you actually are certain you have all the current data. (not a bad idea to delete any older addon data that you aren't using anymore just to tidy up your wow folder anyway)

Anyway, I know this is long winded and my apologies for that, but I didn't want to miss any crucial steps to this working. Hope this helps someone! ~ta
Thank you, this works.
jmcgrath is offline Report comment to moderator  
Reply With Quote
Unread 03-27-11, 06:22 PM  
kyky123
A Kobold Labourer

Forum posts: 0
File comments: 1
Uploads: 0
I think I got it! :)

Originally posted by pceric
There is no such version (yet).

I just pushed a new version with updated libraries but at this point I'm grasping at straws as to why it doesn't show up for a few people. Most likely it is due to one or more old and/or broken addons.
I was having the same issue and I may have figured out how to fix it. Although, I tried about 3 things, so maybe only one really works, but I'll let you know what I did.

I'm running the 6.03 beta version of AltasLoot Enhanced. And AtlasLootReverse hasn't worked for me since about 2 versions prior. Finally I went through my old settings. WTF/Account/"YOUR ACCOUNT NAME"/.... and from here I went under each of my characters and deleted the "AddOns.txt" files and then I made sure to delete any *.lua and *.lua.bak files associated with Atlas (of any version) and any unused addons. I don't recall any of this working until I went under the "Saved Variables" folder and deleted ALL of the *.lua and *.lua.bak files associated with Altas anything though, so maybe that is really the trick. Then I REINSTALLED AtlasLootReverse. (Since I realized that I deleted the reference file for this to work previously <.< oops. Should be larger than a few KB in size - mine is 778KB)

After all of my tedious fidgeting with these files, I restarted WoW again and this time it worked (there should be a message in your chat window about recompiling the dataset for AtlasLoot Reverse or something of that nature).

I had previously deleted these files for individual characters and it hadn't worked at all, so it's possible the combination of things made it so. But after deleting any *.lua & *.lua.bak files, you have to make sure to reinstall this addon so that you actually are certain you have all the current data. (not a bad idea to delete any older addon data that you aren't using anymore just to tidy up your wow folder anyway)

Anyway, I know this is long winded and my apologies for that, but I didn't want to miss any crucial steps to this working. Hope this helps someone! ~ta
kyky123 is offline Report comment to moderator  
Reply With Quote
Unread 03-15-11, 09:13 PM  
pceric
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 38
Uploads: 0
Originally posted by Kite874
is this gonna see an update for ALE 6.03? it just refuses to work, no errors or nothing.
There is no such version (yet).

I just pushed a new version with updated libraries but at this point I'm grasping at straws as to why it doesn't show up for a few people. Most likely it is due to one or more old and/or broken addons.
pceric is offline Report comment to moderator  
Reply With Quote
Unread 03-14-11, 01:32 AM  
Civrock
A Murloc Raider
 
Civrock's Avatar

Forum posts: 4
File comments: 53
Uploads: 0
Also wondering if you could update this addon for the latest version of ALE. I looked at the code but didn't see anything obvious to adjust, like a simple ALE version check, and I'm not good enough with LUA to figure it out.

Thanks!
Last edited by Civrock : 03-14-11 at 01:33 AM.
Civrock is offline Report comment to moderator  
Reply With Quote
Unread 02-28-11, 06:03 AM  
Kite874
A Kobold Labourer

Forum posts: 0
File comments: 19
Uploads: 0
is this gonna see an update for ALE 6.03? it just refuses to work, no errors or nothing.
Last edited by Kite874 : 02-28-11 at 06:04 AM.
Kite874 is offline Report comment to moderator  
Reply With Quote
Unread 02-03-11, 11:13 AM  
Gvaz
A Kobold Labourer

Forum posts: 0
File comments: 16
Uploads: 0
I'm getting the same error as the previous poster.
Gvaz is offline Report comment to moderator  
Reply With Quote
Unread 01-30-11, 09:42 PM  
cry4dawn
A Kobold Labourer

Forum posts: 0
File comments: 16
Uploads: 0
Yet another person with an error since the patch

Date: 2011-01-30 19:39:37
ID: 1
Error occured in: Global
Count: 1
Message: ...terface\AddOns\AtlasLootReverse\AtlasLootReverse.lua line 99:
attempt to index field 'Info' (a nil value)
Debug:
(tail call): ?
...terface\AddOns\AtlasLootReverse\AtlasLootReverse.lua:99:
...terface\AddOns\AtlasLootReverse\AtlasLootReverse.lua:60
(tail call): ?
[C]: ?
[string "safecall Dispatcher[1]"]:9:
[string "safecall Dispatcher[1]"]:5
(tail call): ?
...\AddOns\AtlasLoot\Libs\AceAddon-3.0\AceAddon-3.0.lua:543: EnableAddon()
...\AddOns\AtlasLoot\Libs\AceAddon-3.0\AceAddon-3.0.lua:635:
...\AddOns\AtlasLoot\Libs\AceAddon-3.0\AceAddon-3.0.lua:621
[C]: LoadAddOn()
..\FrameXML\UIParent.lua:242: UIParentLoadAddOn()
..\FrameXML\UIParent.lua:316: TimeManager_LoadUI()
..\FrameXML\UIParent.lua:517:
..\FrameXML\UIParent.lua:492
cry4dawn is offline Report comment to moderator  
Reply With Quote
Unread 01-30-11, 09:07 PM  
pceric
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 38
Uploads: 0
Originally posted by alanm26
I just updated Atlasloot to 6.02.00, which seems incompatable with this addon now.

1x AtlasLootReverse-1.11\AtlasLootReverse.lua:99: attempt to index field 'Info' (a nil value)
(tail call): ?:
<in C code>: ?
<string>:"safecall Dispatcher[1]":9: in function <[string "safecall Dispatcher[1]"]:5>
(tail call): ?:
AceAddon-3.0-10 (Ace3):543: in function `EnableAddon'
AceAddon-3.0-10 (Ace3):635: in function <Ace3\AceAddon-3.0\AceAddon-3.0.lua:621>
<in C code>: in function `LoadAddOn'
Interface\FrameXML\UIParent.lua:242: in function `UIParentLoadAddOn':
Interface\FrameXML\UIParent.lua:265: in function `CombatLog_LoadUI':
Interface\FrameXML\UIParent.lua:519: in function <Interface\FrameXML\UIParent.lua:492>:

---
Just pushed a new version that fixes this error with the new v6.02 ALE.
pceric is offline Report comment to moderator  
Reply With Quote
Unread 01-30-11, 08:33 PM  
pceric
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 38
Uploads: 0
Re: Re: Re: Works for some

Originally posted by Petrah
Any ETA when you will fix your addon so that it reads the info from an updated version of ALE for everyone and not just some?
I don't think there is anything to fix. It is just reading the static data from ALE, it doesn't matter who it is. I would try deleting all the ALE dirs and the AtlasLootReverse saved variables in WTF and reinstall those mods. If it still doesn't work you can pm me your AtlasLootReverse saved variables file and I can see if anything looks strange.
pceric is offline Report comment to moderator  
Reply With Quote
Unread 01-30-11, 08:30 PM  
madhaxor79
A Defias Bandit

Forum posts: 3
File comments: 19
Uploads: 0
getting this error
Code:
Message: ...terface\AddOns\AtlasLootReverse\AtlasLootReverse.lua:99: attempt to index field 'Info' (a nil value)
Time: 01/30/11 20:28:44
Count: 1
Stack: ...terface\AddOns\AtlasLootReverse\AtlasLootReverse.lua:99: in function <...terface\AddOns\AtlasLootReverse\AtlasLootReverse.lua:60>
(tail call): ?
[C]: ?
[string "safecall Dispatcher[1]"]:9: in function <[string "safecall Dispatcher[1]"]:5>
(tail call): ?
...\AddOns\AtlasLoot\Libs\AceAddon-3.0\AceAddon-3.0.lua:543: in function `EnableAddon'
...\AddOns\AtlasLoot\Libs\AceAddon-3.0\AceAddon-3.0.lua:635: in function <...\AddOns\AtlasLoot\Libs\AceAddon-3.0\AceAddon-3.0.lua:621>
[C]: in function `LoadAddOn'
Interface\FrameXML\UIParent.lua:242: in function `UIParentLoadAddOn'
Interface\FrameXML\UIParent.lua:316: in function `TimeManager_LoadUI'
Interface\FrameXML\UIParent.lua:517: in function <Interface\FrameXML\UIParent.lua:492>

Locals: <none>
madhaxor79 is offline Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: