Download
(85 Kb)
Download
Updated: 12-02-11 02:13 PM
Patch for:
Livestock.
Pictures
File Info
Updated:12-02-11 02:13 PM
Created:10-17-10 10:49 AM
Downloads:5,541
Favorites:49
MD5:
Livestock - Cataclysm  Popular! (More than 5000 hits)
Version: 1.5.3
by: Kharthus [More]
This fixes Livestock to work with Cataclysm and contains important bug fixes and improvements.

Original version is here: Livestock

Livestock: For all your companion needs


12/16/11: All future updates will be back on the main addon page.
Version 1.5.3

- TOC update for WoW 4.3

Version 1.5.2

- Add support for camouflage

Version 1.5.1

- Added exceptions for swimming turtle mounts

Version 1.5

- Separated ground and flying mount selections (Thanks XDragonX)
- Mount detection overhaul

Version 1.4.2

- Attempt to fix incorrect ground mount after login

Version 1.4.1

- Cleanup flying mounts that can also be ground mounts

Version 1.4.0

- TOC update for WoW 4.2.0
- Added Winged Guardian

Version 1.3.9

- TOC update for WoW 4.1.0

Version 1.3.8

- Wintergrasp fix

Version 1.3.7

- Updated Spanish localization

Version 1.3.6

- Updated French localization

Version 1.3.5

- Fixed mounting in Outlands when you can't fly yet

Version 1.3.4

- Added Running Wild support (Thanks bwrader)
- Fixed mount categories (Thanks bwrader)
- Added Abyssal Seahorse and Sea Turtle support
- Removed slow mounts since all mounts are now the same speed
- Allow flying from the surface of the water

Version 1.3.3

- Increased menu size to 30

Version 1.3.2

- Added debug reporting to help solve problems

Version 1.3.1

- Small fix for the mount delay right after combat
- Revert AotP/AotC in combat change due to same fix

Version 1.3.0

- Fixed ghostwolf when indoors
- Fixed errors from trying to mount in combat

Version 1.2.9

- Allow hunters to cast AotP/AotC in combat to fix timing issue

Version 1.2.8

- Fixed secure state handler
- Added mounting while swimming

Version 1.2.7

- Fixed mounts in Azeroth

Version 1.2.6

- Fixed CatForm, AotP/AotC, GhostWolf when indoors.

Version 1.2.5

- Fixed Shaman mounting.

Version 1.2.4

- Fixed Druid mounting.
- Fixed corrupted mount tables when using NPCScan and locked creaturecache files.

Version 1.2.3

- Incorporated aberant's changes with a bunch of stuff that had been posted here to fix issues with vehicle UI taint and hunters not able to mount right after combat.
Archived Files (23)
File Name
Version
Size
Author
Date
1.5.2
84kB
Kharthus
08-15-11 02:20 AM
1.5.1
84kB
Kharthus
08-13-11 10:29 PM
1.5
84kB
Kharthus
08-13-11 05:24 PM
1.4.2
84kB
Kharthus
07-13-11 12:57 AM
1.4.1
85kB
Kharthus
07-09-11 12:07 PM
1.4.0
85kB
Kharthus
06-28-11 07:18 PM
1.3.9
84kB
Kharthus
04-26-11 09:24 PM
1.3.8
84kB
Kharthus
03-26-11 01:53 PM
1.3.7
84kB
Kharthus
02-20-11 10:02 AM
1.3.6
84kB
Kharthus
02-19-11 05:56 PM
1.3.5
83kB
Kharthus
02-01-11 12:03 AM
1.3.4
83kB
Kharthus
01-08-11 09:33 PM
1.3.3
83kB
Kharthus
01-02-11 04:14 AM
1.3.2
83kB
Kharthus
12-22-10 12:29 AM
1.3.1
83kB
Kharthus
12-15-10 04:20 AM
1.3.0
83kB
Kharthus
12-07-10 11:37 PM
1.2.9
83kB
Kharthus
12-05-10 05:28 PM
1.2.8
83kB
Kharthus
12-04-10 04:06 PM
1.2.7
83kB
Kharthus
11-27-10 02:06 AM
1.2.6
83kB
Kharthus
11-14-10 09:12 AM
1.2.5
83kB
Kharthus
10-27-10 07:50 AM
1.2.4
81kB
Kharthus
10-24-10 08:54 PM
1.2.3
81kB
Kharthus
10-17-10 10:49 AM


Post A Reply Comment Options
Old 12-28-10, 10:45 AM  
Aileen
A Fallenroot Satyr
AddOn Author - Click to view AddOns

Forum posts: 28
File comments: 73
Uploads: 2
Not really a major issue but would it be possible to make the lists of pets/mounts longer? I have the little popup anchor thing pushed all the way to the left edge of my screen but I am about 5 minipets away from being out of horizontal space for pet lists. I have 8 menus showing, and the 8th one is already hanging over the right edge of my screen.
Aileen is offline Report comment to moderator  
Reply With Quote
Old 12-22-10, 11:21 AM  
naboomkin
A Kobold Labourer

Forum posts: 0
File comments: 12
Uploads: 0
Re: Re: Re: Re: Re: Re: Re: Re: Smartmounting Underwater?

Originally posted by Kharthus
Try blowing away the SavedVariables file and see what happens.

If that still doesn't work I might have to send you a test version so I can see where in the code it's getting hung up.

UPDATE: Try loading v1.3.2 and using the '/livestock debug' command. That will print out some useful information that will help me figure out why that's happening.
Blowing the saved variables fixed it.

My guess is that it will fix my husband's also -- I'll let you know if it doesn't. I apologize I didn't do this earlier; I just try to avoid it if possible, using it as a last resort.

Also, now that I think about it, I've been having random bugs relatively recently when it comes to mounting up in certain instances (where it's allowed; AQ comes to mind). I wonder if whatever got borked in the SVs will fix that also -- or if it's a different issue altogether.

Thanks again for your time and input on this.
naboomkin is offline Report comment to moderator  
Reply With Quote
Old 12-21-10, 11:57 PM  
Kharthus
A Murloc Raider
AddOn Author - Click to view AddOns

Forum posts: 8
File comments: 227
Uploads: 6
Re: Re: Re: Re: Re: Re: Re: Smartmounting Underwater?

Try blowing away the SavedVariables file and see what happens.

If that still doesn't work I might have to send you a test version so I can see where in the code it's getting hung up.

UPDATE: Try loading v1.3.2 and using the '/livestock debug' command. That will print out some useful information that will help me figure out why that's happening.
Last edited by Kharthus : 12-22-10 at 12:30 AM.
Kharthus is offline Report comment to moderator  
Reply With Quote
Old 12-21-10, 06:19 PM  
naboomkin
A Kobold Labourer

Forum posts: 0
File comments: 12
Uploads: 0
Re: Re: Re: Re: Re: Re: Smartmounting Underwater?

Originally posted by Kharthus
Hmmmm, it works fine on my druid. Are you playing on enUS or a different localization?

What does your macro look like?

It should be /click LivestockComboButton.
enUS localization for both of us.

Both of our hotkeys are bound through the game's keybinding interface, under "Livestock" and the "smart mount" button. We don't use a separate macro, per se.
naboomkin is offline Report comment to moderator  
Reply With Quote
Old 12-21-10, 06:07 PM  
Kharthus
A Murloc Raider
AddOn Author - Click to view AddOns

Forum posts: 8
File comments: 227
Uploads: 6
Re: Re: Re: Re: Re: Smartmounting Underwater?

Originally posted by naboomkin
I am running the latest version, yes. Also, I delete the previous version of the mod prior to installing, and have not yet attempted to kill the saved variables on it.

As far as I can tell it broke with the pre-Cata patch. I'm not completely sure if it was 4.0.1 or 4.0.3. However, my husband's main is also a druid and it is not working for him either.

I wonder if any other druids out there are having problems?
Hmmmm, it works fine on my druid. Are you playing on enUS or a different localization?

What does your macro look like?

It should be /click LivestockComboButton.
Kharthus is offline Report comment to moderator  
Reply With Quote
Old 12-21-10, 04:50 PM  
naboomkin
A Kobold Labourer

Forum posts: 0
File comments: 12
Uploads: 0
Re: Re: Re: Re: Smartmounting Underwater?

Originally posted by Kharthus
Are you running the latest version of Livestock? When exactly did it break?
I am running the latest version, yes. Also, I delete the previous version of the mod prior to installing, and have not yet attempted to kill the saved variables on it.

As far as I can tell it broke with the pre-Cata patch. I'm not completely sure if it was 4.0.1 or 4.0.3. However, my husband's main is also a druid and it is not working for him either.

I wonder if any other druids out there are having problems?
naboomkin is offline Report comment to moderator  
Reply With Quote
Old 12-21-10, 04:44 PM  
Kharthus
A Murloc Raider
AddOn Author - Click to view AddOns

Forum posts: 8
File comments: 227
Uploads: 6
Re: Re: Re: Smartmounting Underwater?

Originally posted by naboomkin
Well that is interesting.

For some reason it isn't working for me anymore. When I use my smart mount hotkey in water, nothing happens. It started happening after the patch, so I figured that was what broke it.

Any thoughts?
Are you running the latest version of Livestock? When exactly did it break?
Kharthus is offline Report comment to moderator  
Reply With Quote
Old 12-21-10, 03:21 PM  
naboomkin
A Kobold Labourer

Forum posts: 0
File comments: 12
Uploads: 0
Re: Re: Smartmounting Underwater?

Originally posted by Kharthus
Turns out there was never actually an option to turn druid swimming on/off. It is always on by default and it still works with the latest version.
Well that is interesting.

For some reason it isn't working for me anymore. When I use my smart mount hotkey in water, nothing happens. It started happening after the patch, so I figured that was what broke it.

Any thoughts?
naboomkin is offline Report comment to moderator  
Reply With Quote
Old 12-21-10, 03:10 PM  
Kharthus
A Murloc Raider
AddOn Author - Click to view AddOns

Forum posts: 8
File comments: 227
Uploads: 6
Re: Smartmounting Underwater?

Turns out there was never actually an option to turn druid swimming on/off. It is always on by default and it still works with the latest version.
Kharthus is offline Report comment to moderator  
Reply With Quote
Old 12-21-10, 02:50 PM  
naboomkin
A Kobold Labourer

Forum posts: 0
File comments: 12
Uploads: 0
Smartmounting Underwater?

I apologize in advance if I missed a post about this somewhere.

Prior to the last patch, Livestock provided druids with the ability to use smartmounting underwater -- i.e., summoning a mount switched you into water form (also known as rabid seal form ). For some reason this option is no longer in the Livestock configuration menu. In contrast, the options for smartmounting into flight form, travel form, and kitty form are still present and working appropriately.

What happened to the smartmounting underwater? Is it possible to get this feature back?

Was the removal of this option a result of the things that are broken in livestock right now?

Thanks for your time.
naboomkin is offline Report comment to moderator  
Reply With Quote
Old 12-20-10, 02:36 PM  
Kharthus
A Murloc Raider
AddOn Author - Click to view AddOns

Forum posts: 8
File comments: 227
Uploads: 6
Originally posted by Steil
is the only way to set a favorite companion per zone? Looking for a way to set an overall one to avoid having to set it for each new zone/subzone.
If you only want one pet, just turn all the other pets off from the /livestock screen.
Kharthus is offline Report comment to moderator  
Reply With Quote
Old 12-20-10, 09:46 AM  
Steil
A Cliff Giant
 
Steil's Avatar

Forum posts: 77
File comments: 47
Uploads: 0
is the only way to set a favorite companion per zone? Looking for a way to set an overall one to avoid having to set it for each new zone/subzone.
Steil is offline Report comment to moderator  
Reply With Quote
Old 12-12-10, 03:48 AM  
Kharthus
A Murloc Raider
AddOn Author - Click to view AddOns

Forum posts: 8
File comments: 227
Uploads: 6
Re: Re: Frostbrood Vanquisher

Once again...

Originally posted by Kharthus
Mount detection is totally broken at the moment. The only fix is to hand edit the SavedVariables file.
The valid choices are "land", "flying", "variable".
Kharthus is offline Report comment to moderator  
Reply With Quote
Old 12-12-10, 01:05 AM  
SannaSK
An Aku'mai Servant

Forum posts: 33
File comments: 22
Uploads: 0
my priest is having severe problems with Livestock properly determining which mounts are land and which are flying. Currently, only 'snowy griffon' is tagged as flying, and the other 39 mounts (somewhat evenly split between flying and land, i believe) are all categorized as 'land'. I have deleted the character/sv/livestock.lua files for the priest multiple times, but every time they generate, the mounts are all tagged as land.

I suspect something similar is happening to my warrior, only with a wider range of properly-tagged-as-flying mounts. the warrior has over a hundred mounts, but it seems like only the same 10 ever show up when i click flying. I forgot to look before I logged off at the plain /livestock box to see, but I'll do that next time I get on her.

what information could i, if needed, submit to perhaps assist in diagnosing such an issue? i'm really a lua-nub, some of the SV files i can read ok but actual lua code is beyond me. any help would be appreciated, and i'd like to offer any help i can in return.

--------------------

eta: sorry. i'd read the top few comments but not far enough down to see you post that the first time. sorry : x
Last edited by SannaSK : 12-13-10 at 04:24 PM.
SannaSK is offline Report comment to moderator  
Reply With Quote
Old 12-11-10, 06:46 PM  
Goatbert
A Defias Bandit

Forum posts: 2
File comments: 9
Uploads: 0
Turbostrider

Hello,
For some reason in 1.3.0 (not sure about before), Turbostrider is showing as a flying mount and a land mount, so it comes up sometimes when I mean to mount a flyer and I end up cratering because I tunnel pretty hard.

Turned it off for now but would appreciate if it could be fixed. Thanks!
Goatbert is offline Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: