Minion Beta! - Help us test our new AddOn updater. Get it now!
Download
(87 Kb)
Download
Updated: 10-19-14 05:45 PM
Pictures
File Info
Compatibility:
Warlords of Draenor Pre-Patch (6.0.2)
Updated:10-19-14 05:45 PM
Created:unknown
Downloads:29,310
Favorites:317
MD5:
Livestock  Popular! (More than 5000 hits)
Version: 2.2.0
by: Kharthus [More]
Livestock: For all your companion needs
Now that your pets and mounts don't take up space in your bags, Livestock lets you manage them intelligently. This addon sorts your companions into land mounts, flying mounts, and vanity pets. Then, with the push of a button, you can randomly summon any of the three, or designate a favorite pet to have out on command.

You can also have Livestock always keep a pet by your side, and have it dismiss your vanity pet when you are in PVP battle and it would give away your position.

You can even tell Livestock to put you on a random land or flying mount depending on whether the area you're in lets you fly or not. Underwater or in combat, Livestock can also be configured to cast certain spells relating to travel, such as Path of Frost or Ghost Wolf.

New to version 1.2 and above, you can designate certain pets or mounts to be called in certain zones or subzones. Ride in style on a Frostwolf Howler while in Alterac Valley, and then switch to your favorite color of Mechanostrider while in Ironforge. Livestock will let you make sure that you have your good luck pet out whenever you're in Ulduar or Trial of the Crusader.
You can summon critters, land mounts, and flying mounts in various ways. See the ReadMe file for more information.
Localization Help:
Livestock currently only works for the enUS, deDE, eES, ruRU, and frFR clients. (The client is only localized completely for the enUS client, and assistance in localizing is always appreciated!) If you are on another client, Livestock will load but will show all English strings. If you are willing to help localize the addon for your language, please let me know - you'd only need to provide some simple translations and I'd do the rest. You can reach me through the Private Message system available here.
Slash Commands:
There are currently eight slash commands for the addon. View the ReadMe file for a more in-depth explanation. /livestock and /ls both work for commands.
  • Use "/livestock" to bring up the main menu bar.
  • Use "/livestock reset" to move the four Livestock Buttons back to their default positions.
  • Use "/livestock scale <scale>" to change the size of the Livestock Buttons.
  • Use "/livestock prefs" as a shortcut to access the preferences, described in the ReadMe.
  • Use "/livestock redo" to force Livestock to reset to default. Useful for squashing buggy behavior at the cost of having to reset your settings.
  • Use "/livestock [zone/subzone]" to designate a pet or mount for your current zone or subzone. For more information, check the ReadMe.
  • Use "/livestock [mount/nomount/pet/nopet]" to add/remove pets and mounts from the random summon list. Uses your active summon.
  • Use "/livestock debug" - Prints out useful debugging information that can assist the developers in solving problems. Use the command again to turn off the debugging output.


Livestock Options and Preferences:
You can find the options for Livestock in the Addons tab of the Blizzard Interface options menu. The "Livestock" tab has the major options, while options for pets, Smart Mounting, and zone/subzone preferences are in sub-menus. You can read more about the preferences in the ReadMe file.
Bug Reports and Feature Requests
If you find unexpected behavior in Livestock, especially in locales other than enUS, please check the FAQ first to see if it has been addressed and if there is a possible fix.
Please report any bugs you find with Livestock -- or feature requests you'd like to see -- using the "Report Bugs" or "Feature Request" button underneath the Download button, up and to the right. I appreciate your feedback and support.
If you are reporting a bug, the following information is helpful: Any error messages that you saw, where you were (if you can give coordinates, that's excellent), what you were trying to do, what your menus looked like, and what class you play.
Thanks!
Well-deserved credit goes to the following people:
  • Khanthal (Uldum), for the original idea and being our MT so often!
  • A BIG thank you to Sbo (UI and Macros forum, Live) who helped me figure out what was the issue with Dalaran and Wintergrasp as well as suggesting the way to get around it.
  • Grimgear (UI and Macros forum, Live) for helping troubleshoot a bug, pointing me to keybindings, and suggesting rotation speed. Also for pointing out how best to adjust my GUI to compensate for localization.
  • Lunessa (UI and Macros forum, Live) for pointing me to Blizzard's instructions on creating panels in the Interface menu.
  • Xelron (UI and Macros forum, Live) for helping construct debug messages to get more information and indirectly convincing me to make my own dropdowns.
  • Ro (UI and Macros forum, Beta) for the 3D model viewer idea. Ro also originally suggested making my own custom dropdowns, which I thought was beyond me!
  • Elloria and Tgulics (WoWInterface) for helping spread the word and test the addon in its early stages and for suggesting highlighting the buttons when they're clicked.
  • The MVPs (UI and Macros forum) for providing the resources needed to accomplish this one as well as stepping in and answering my questions from time to time. Special thanks to Alestane and Iriel for helping me with secure handlers.
  • kdkunde (WoWInterface) for helping translate this mod into German so far!
  • Vastilia (WoWInterface) and Yorgl (Curse) for helping translate into French!
  • madbit (WoWInterface) for the Spanish translation.
  • simply (Curse) for the Russian localization.
  • Certainly not least, Brenkite (Uldum) for being my personal troubleshooter and moral support.
Version 2.2.0

- Fixed dragging pets into the Zone/Subzone screen
- Disabled dragging mounts into the Zone/Subzone screen (use the command line)
- Better handling of the new flying mounts in land menu setting
- Moonkins now remain in moonkin form when mounting

Version 2.1.0

- Hide mounts from the opposite faction

Version 2.0.5

- Fixed flying dismounts for non-druids

Version 2.0.4

- New Option: Include flying mounts in land menu
- More druid fixes

Version 2.0.3

- Fixed Death Knights and Paladins
- Additional fixes for Druids

Version 2.0.2

- Support Flight Form when using Glyph of the Stag

Version 2.0.1

- Fixed error on non-hunters

Version 2.0.0

- Support for patch 6.0.2
- Fixed some issues with druid forms
- Low level druids will use cat form until they learn travel form
- Aspect of the Hawk removed (can cancel AotC/AotP when mounting)

Version 1.9.9

- Fixed Outlands flying mounts

Version 1.9.8

- random() changed to fastrandom() for 5.4.2 patch

Version 1.9.7

- TOC update for patch 5.4

Version 1.9.6

- TOC update for patch 5.3
- Now uses flying mounts underwater (instead of land)

Version 1.9.5

- Performance improvements

Version 1.9.4

- Two new options for Aspect of the Hawk
- New option: New mounts are disabled by default

Version 1.9.3

- Fixed Aspect of the Pack in groups

Version 1.9.2

- Updates for patch 5.2

Version 1.9.1

- Fixed flying detection code for Outlands
- Slight update to the new scrolling code
- Added /ls as a shortcut for /livestock

Version 1.9.0

- Added Azure Water Strider option
- Added Zen Flight option
- Added scrollable mount/pet lists
- Fixed code that detects flying skill level and area
- Cleanup Abyssal Seahorse code
- Cleanup localizations
- Removed Crusader Aura

Version 1.8.0

- Updates for patch 5.1
- Another fix for SetWidth errors
- Fixed Aspect of the Pack

- Change log up to this version removed from hosting site and archived in Change Log.txt
Optional Files (0)


Archived Files (55)
File Name
Version
Size
Author
Date
2.1.0
87kB
Kharthus
10-18-14 07:21 PM
2.0.5
86kB
Kharthus
10-17-14 03:24 PM
2.0.4
86kB
Kharthus
10-17-14 01:22 PM
2.0.3
86kB
Kharthus
10-16-14 01:28 AM
2.0.2
86kB
Kharthus
10-15-14 10:42 PM
2.0.1
86kB
Kharthus
10-15-14 12:27 AM
2.0.0
86kB
Kharthus
10-14-14 10:56 PM
1.9.9
87kB
Kharthus
08-16-14 12:15 PM
1.9.8
87kB
Kharthus
12-12-13 09:30 PM
1.9.7
86kB
Kharthus
09-30-13 04:00 AM
1.9.6
86kB
Kharthus
06-15-13 01:57 PM
1.9.5
86kB
Kharthus
03-24-13 07:20 PM
1.9.4
86kB
Kharthus
03-19-13 08:23 PM
1.9.3
86kB
Kharthus
03-19-13 06:18 PM
1.9.2
86kB
Kharthus
03-05-13 08:09 PM
1.9.1
86kB
Kharthus
03-04-13 11:51 PM
1.9.0
86kB
Kharthus
03-03-13 06:46 PM
1.8.0
89kB
Kharthus
11-28-12 10:16 PM
1.7.12
89kB
Kharthus
11-12-12 07:35 PM
1.7.11
89kB
Kharthus
11-10-12 01:24 PM
1.7.10
89kB
Kharthus
11-05-12 10:11 PM
1.7.9
89kB
Kharthus
11-05-12 08:32 PM
1.7.8
89kB
Kharthus
11-02-12 11:59 AM
1.7.7
89kB
Kharthus
10-29-12 02:19 AM
1.7.6
89kB
Kharthus
10-28-12 09:37 PM
1.7.5
89kB
Kharthus
10-28-12 08:24 PM
1.7.4
89kB
Kharthus
10-22-12 10:32 PM
1.7.3
89kB
Kharthus
10-22-12 12:09 AM
1.7.2
89kB
Kharthus
10-21-12 03:31 PM
1.7.1
88kB
Kharthus
10-20-12 02:25 PM
1.7.0
88kB
Kharthus
10-19-12 04:08 PM
1.6.9
88kB
Kharthus
10-07-12 09:26 PM
1.6.8
88kB
Kharthus
10-05-12 03:25 PM
1.6.7
87kB
Kharthus
09-25-12 08:06 PM
1.6.6
87kB
Kharthus
09-21-12 06:53 PM
1.6.5
87kB
Kharthus
09-11-12 01:28 AM
1.6.4
87kB
Kharthus
09-02-12 01:07 PM
1.6.3
86kB
Kharthus
09-02-12 10:26 AM
1.6.2
86kB
Kharthus
09-01-12 09:57 AM
1.6.1
86kB
Kharthus
08-31-12 07:53 PM
1.6.0
86kB
Kharthus
08-27-12 10:49 PM
1.5.4
85kB
Kharthus
01-09-12 09:19 PM
1.5.3
84kB
Kharthus
12-16-11 02:31 PM
1.2.2
81kB
Kharthus
01-05-10 11:59 PM
1.2.1
80kB
Recompense
11-11-09 06:55 AM
1.2
78kB
Recompense
10-20-09 09:49 PM
1.1.8
76kB
Recompense
10-19-09 01:20 PM
1.1.7
76kB
Recompense
08-12-09 08:07 PM
1.1.6
83kB
Recompense
02-26-09 02:59 PM
1.1.5
80kB
Recompense
01-08-09 03:13 AM
1.1.4
76kB
Recompense
12-16-08 04:24 PM
1.1.3
76kB
Recompense
12-07-08 04:33 PM
1.1.2
76kB
Recompense
11-30-08 11:49 PM
1.1.1
76kB
Recompense
11-23-08 05:19 PM
1.1
75kB
Recompense
11-15-08 06:37 AM


Post A Reply Comment Options
Unread 11-03-12, 10:23 AM  
Kharthus
A Murloc Raider
AddOn Author - Click to view AddOns

Forum posts: 8
File comments: 238
Uploads: 6
Re: Very strange behaviour on one single character

Are you getting any errors?

Try /livestock debug and then your mount button and see what it reports. Since it's in Pandaria, it might be trying to summon a flying mount you can't use yet (it shouldn't).
Kharthus is offline Report comment to moderator  
Reply With Quote
Unread 11-03-12, 02:15 AM  
capcanuk
A Kobold Labourer

Forum posts: 0
File comments: 28
Uploads: 0
Very strange behaviour on one single character

For some odd reason, my key-bind to launch "smart mount" suddenly stopped working on one toon.

I have all of my accounts, all of my toons, with the keybind " - " for smart mount, and "shift - " for force ground mount.

On this single toon, "shift - " works and calls up the ground mount.

but just " - " won't call up the smart mount. If I am already mounted (by going through the game's menu options) pressing " - " WILL dismount, so I know that it's not a keyboard issue (I can easily type a bunch of --------- in chat).

this just started all of a sudden while I was questing in Pandaria. I am only 86 on that toon, still doing Jade Forest.
capcanuk is offline Report comment to moderator  
Reply With Quote
Unread 10-23-12, 10:14 PM  
Kharthus
A Murloc Raider
AddOn Author - Click to view AddOns

Forum posts: 8
File comments: 238
Uploads: 6
Re: Re: Re: SetWidth/GetWidth

Originally Posted by Emli
Originally Posted by Kharthus
Can you please try to figure out which variable is wrong and where it's getting off by one? I have another report on Curse, but I have never seen this problem so I have no way to troubleshoot what's causing it.
Yeah, I know I can avoid the issue, but I really want to know why the count is getting messed up. Especially since I don't see it on my machine.
Kharthus is offline Report comment to moderator  
Reply With Quote
Unread 10-23-12, 09:51 PM  
Emli
A Murloc Raider

Forum posts: 5
File comments: 7
Uploads: 1
Re: Re: SetWidth/GetWidth

Originally Posted by Kharthus
Can you please try to figure out which variable is wrong and where it's getting off by one? I have another report on Curse, but I have never seen this problem so I have no way to troubleshoot what's causing it.
Basically, anywhere that you're using a constructed text string to reference a UI element, you should check to make sure it exists before you use it. Here is the code I changed in Livestock.lua:

Code:
(Line 418)	if (text) then
		text:SetText( name )
		tinsert(texttable, text) 
	end

(Line 467)	if button == endButton and token and currentMenu then 
		for i = 1, endButton do
			if (_G["Livestock"..token.."Menu"..currentMenu.."Button"..i.."Text"]) then
				local textwidth = _G["Livestock"..token.."Menu"..currentMenu.."Button"..i.."Text"]:GetWidth()
				if textwidth > maxWidth then
						maxWidth = textwidth + 20
				end
			end
		end

		for i = 1, endButton do				
			if (_G["Livestock"..token.."Menu"..currentMenu.."Button"..i]) then
				_G["Livestock"..token.."Menu"..currentMenu.."Button"..i]:SetWidth(maxWidth)
			end
		end
	end
It's not the best code, but it fixed the errors. I can send you my actual file if that would be easier.
Last edited by Emli : 10-23-12 at 09:54 PM.
Emli is offline Report comment to moderator  
Reply With Quote
Unread 10-23-12, 07:21 PM  
Kharthus
A Murloc Raider
AddOn Author - Click to view AddOns

Forum posts: 8
File comments: 238
Uploads: 6
Re: SetWidth/GetWidth

Originally Posted by Emli
I've been getting errors with SetWidth/GetWidth ever since the update that increased the menu size. I fixed it locally by checking to make sure the UI element referenced in the loops in BuildMenu (around line 474) was not null before trying to call those functions. I suspect there's some sort of off by one error happening in the loop, but since the null check fixed the problem for me, I didn't investigate further.

Let me know if you'd like more details.
Can you please try to figure out which variable is wrong and where it's getting off by one? I have another report on Curse, but I have never seen this problem so I have no way to troubleshoot what's causing it.
Kharthus is offline Report comment to moderator  
Reply With Quote
Unread 10-23-12, 10:05 AM  
Emli
A Murloc Raider

Forum posts: 5
File comments: 7
Uploads: 1
SetWidth/GetWidth

I've been getting errors with SetWidth/GetWidth ever since the update that increased the menu size. I fixed it locally by checking to make sure the UI element referenced in the loops in BuildMenu (around line 474) was not null before trying to call those functions. I suspect there's some sort of off by one error happening in the loop, but since the null check fixed the problem for me, I didn't investigate further.

Let me know if you'd like more details.
Emli is offline Report comment to moderator  
Reply With Quote
Unread 10-23-12, 09:50 AM  
bkerwin
A Defias Bandit

Forum posts: 3
File comments: 21
Uploads: 0
Originally Posted by Kharthus
Originally Posted by Dridzt
Just to chip in here that I've also been having this issue.

I alleviated the problem by doing a /reload after re-selecting my pets/mounts before exiting the game.
That seemed to make it stick and since it's a minor inconvenience anyway I didn't bother to debug further.

Just adding this here to say that if it's fixed I'll probably be able to provide confirmation on my end as well since I'm one of the lucky minority where loading process events (as well as exit?) don't fire in the same order as for most.
I believe 1.7.4 fixes it for good. I reverted a few changes and it should work like 1.7.0 again (hopefully).
Seems to be working for me. Thanks!
bkerwin is offline Report comment to moderator  
Reply With Quote
Unread 10-23-12, 07:19 AM  
Kharthus
A Murloc Raider
AddOn Author - Click to view AddOns

Forum posts: 8
File comments: 238
Uploads: 6
Originally Posted by Dridzt
Just to chip in here that I've also been having this issue.

I alleviated the problem by doing a /reload after re-selecting my pets/mounts before exiting the game.
That seemed to make it stick and since it's a minor inconvenience anyway I didn't bother to debug further.

Just adding this here to say that if it's fixed I'll probably be able to provide confirmation on my end as well since I'm one of the lucky minority where loading process events (as well as exit?) don't fire in the same order as for most.
I believe 1.7.4 fixes it for good. I reverted a few changes and it should work like 1.7.0 again (hopefully).
Kharthus is offline Report comment to moderator  
Reply With Quote
Unread 10-23-12, 12:31 AM  
Dridzt
A Pyroguard Emberseer
 
Dridzt's Avatar
AddOn Author - Click to view AddOns

Forum posts: 1191
File comments: 780
Uploads: 82
Just to chip in here that I've also been having this issue.

I alleviated the problem by doing a /reload after re-selecting my pets/mounts before exiting the game.
That seemed to make it stick and since it's a minor inconvenience anyway I didn't bother to debug further.

Just adding this here to say that if it's fixed I'll probably be able to provide confirmation on my end as well since I'm one of the lucky minority where loading process events (as well as exit?) don't fire in the same order as for most.
Dridzt is offline Report comment to moderator  
Reply With Quote
Unread 10-22-12, 09:03 PM  
bkerwin
A Defias Bandit

Forum posts: 3
File comments: 21
Uploads: 0
Originally Posted by Kharthus
Originally Posted by bkerwin
It's still happening with 1.7.3. If it helps at all, the mount/pet selections aren't reset if I reload the ui, only after completely exiting the game and starting it up again.
I'll put up another attempt tonight. There's some weird event timing thing that is different on different machines (I think). If the next version doesn't fix it, we can try a few things off-line so I don't have to spam everyone with releases.
Sounds good.. yeah my girlfriend isn't having the issue so it's not universal apparently. Just let me know.
bkerwin is offline Report comment to moderator  
Reply With Quote
Unread 10-22-12, 07:37 PM  
Kharthus
A Murloc Raider
AddOn Author - Click to view AddOns

Forum posts: 8
File comments: 238
Uploads: 6
Originally Posted by bkerwin
It's still happening with 1.7.3. If it helps at all, the mount/pet selections aren't reset if I reload the ui, only after completely exiting the game and starting it up again.
I'll put up another attempt tonight. There's some weird event timing thing that is different on different machines (I think). If the next version doesn't fix it, we can try a few things off-line so I don't have to spam everyone with releases.
Kharthus is offline Report comment to moderator  
Reply With Quote
Unread 10-22-12, 08:50 AM  
bkerwin
A Defias Bandit

Forum posts: 3
File comments: 21
Uploads: 0
Originally Posted by Kharthus
Originally Posted by bkerwin
Started having this issue with version 1.7.0 or maybe 1.7.1 - every time I log in all of my mount/pet selections are reset. So I have to go back and deselect the mounts/pets I don't want to use but the next time I log in they are all enabled again. I've tried deleting the Livestock.lus SavedVariables file and redoing it but it hasn't helped.
Try 1.7.3. I think I fixed it, but not entirely sure.

It's still happening with 1.7.3. If it helps at all, the mount/pet selections aren't reset if I reload the ui, only after completely exiting the game and starting it up again.
Last edited by bkerwin : 10-22-12 at 09:31 AM.
bkerwin is offline Report comment to moderator  
Reply With Quote
Unread 10-22-12, 12:08 AM  
Kharthus
A Murloc Raider
AddOn Author - Click to view AddOns

Forum posts: 8
File comments: 238
Uploads: 6
Originally Posted by sindalee
would much rather fly from the surface, is easy enough to have a seperate kb for a water mount, or even click the darned thing for how little use they really get.
If you click off the buff, it will also work correctly.
Last edited by Kharthus : 10-22-12 at 12:08 AM.
Kharthus is offline Report comment to moderator  
Reply With Quote
Unread 10-22-12, 12:07 AM  
Kharthus
A Murloc Raider
AddOn Author - Click to view AddOns

Forum posts: 8
File comments: 238
Uploads: 6
Originally Posted by bkerwin
Started having this issue with version 1.7.0 or maybe 1.7.1 - every time I log in all of my mount/pet selections are reset. So I have to go back and deselect the mounts/pets I don't want to use but the next time I log in they are all enabled again. I've tried deleting the Livestock.lus SavedVariables file and redoing it but it hasn't helped.
Try 1.7.3. I think I fixed it, but not entirely sure.
Kharthus is offline Report comment to moderator  
Reply With Quote
Unread 10-21-12, 11:08 PM  
bkerwin
A Defias Bandit

Forum posts: 3
File comments: 21
Uploads: 0
Started having this issue with version 1.7.0 or maybe 1.7.1 - every time I log in all of my mount/pet selections are reset. So I have to go back and deselect the mounts/pets I don't want to use but the next time I log in they are all enabled again. I've tried deleting the Livestock.lus SavedVariables file and redoing it but it hasn't helped.
bkerwin is offline Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: